Installation and Upgrade Notes

Before installing or upgrading to Version 5.1.0, read the following sections.

Quick Installer No Longer Supported

The Quick Installer was deprecated in Version 5.0 and is no longer supported in Version 5.1.0. The MapR Installer web interface is recommended for Version 5.1.0 installations.

Rolling Upgrades

Rolling upgrades are supported from all 4.x versions to Version 5.1.0.

Enabling New Features

When upgrading, new features can be enabled using the maprcli cluster feature enable command. In addition, features can be listed using the maprcli cluster feature list command.

Note: The maprcli config save command is no longer available for enabling features.

Support for Oracle Linux

The MapR Version 5.1 Core package supports the Oracle Linux operating system. To install Version 5.1 Core on Oracle Linux, use the manual command-line installation instructions.

The MapR Installer does not support Oracle Linux installations, and MapR ecosystem packages cannot be installed on Oracle Linux.

MapR Client Compatibility

In general, Version 4.x and 5.0 MapR clients will continue to work against a cluster that is upgraded to Version 5.1.0.

Note: The RM HA configuration on the client must match the configuration on the cluster. For example, zero-configuration RM HA was not supported in Version 4.0.1 so a Version 4.0.1 YARN client will not work with a Version 5.1.0 RM HA cluster.

MapR Interoperability Matrix

See the Interoperability Matrix pages for detailed information about MapR server, JDK, client, and ecosystem compatibility.