Packages and Dependencies for MapR 5.2

Details about packages and dependencies for the MapR software and Hadoop ecosystem components for the MapR 5.2 release.

Note: For maintenance release packages and dependencies, see Packages and Dependencies for MapR 5.2.1 or Packages and Dependencies for MapR 5.2.2.

This page lists the packages and dependencies for the MapR software and Hadoop ecosystem components for the MapR 5.2 release. The Package Dependencies section lists the non-MapR packages that the MapR distribution depends on. The Node Roles, Packages and Dependencies section lists the packages that contain each MapR component, and their dependencies.

Package Dependencies

This section contains dependencies for the MapR software for each supported version of Linux:
Packages and Dependencies for Oracle
Make sure that the following package is installed on each node:
MapR 5.2.0 mapr-compat-oel-5.2.0.39122.GA-1.x86_64.rpm
Package Dependencies for Red Hat and CentOS
Make sure the following packages are installed on each node:
  • bash
  • curl
  • rpcbind
  • dmidecode
  • glibc
  • hdparm
  • initscripts
  • iputils
  • irqbalance
  • libgcc
  • libstdc++
  • nss (version 3.19 or greater)
  • perl
  • redhat-lsb-core
  • rpm-libs
  • sdparm
  • shadow-utils
  • syslinux
  • unzip
  • zip

On ZooKeeper nodes, nc is required for netcat. On nodes running the Metrics service, soci-mysql is required. Installing the Metrics service requires the presence of the EPEL (Extra Packages for Enterprise Linux) repository.

Package Dependencies for SUSE
All package dependencies for Red Hat are also applicable for SUSE. Installing on SUSE also requires the following packages to be installed:
  • aaa_base
  • curl
MapR 5.2.0 mapr-compat-suse-5.2.0.39122.GA-1.x86_64.rpm
Package Dependencies for Ubuntu
Make sure the following packages are installed on each node:
  • adduser
  • awk
  • bash
  • curl
  • coreutils
  • dmidecode
  • dpkg-repack
  • grep
  • hdparm
  • iputils-arping
  • irqbalance
  • libc6
  • libgcc1
  • libstdc++6
  • lsb-base
  • nfs-common
  • perl
  • procps
  • sdparm
  • sed
  • syslinux
  • sysvinit-utils
  • unzip
  • zip
On ZooKeeper nodes, nc is required for netcat. If setting up a local repository, the following packages are required on the repository machine:
  • dpkg-dev
  • apache2

Node Roles, Packages and Dependencies for MapR 5.2.0

This section lists the roles (services) that you can install on a node, which package implements each specific role, and the dependencies for each role. Package files for Red Hat, CentOS, and SUSE distributions have extension *.rpm. Package files for the Ubuntu distribution have extension *.deb. The table lists package files ending in rpm only, but each package has an equivalent deb file for Ubuntu.

The following table provides a list of MapR roles and the associated package for each role, as well as the dependency packages that each role requires.

Role Package Internal Dependencies
CLDB mapr-cldb-5.2.0.39122.GA-1.x86_64.rpm

mapr-core-5.2.0.39122.GA-1.x86_64.rpm

mapr-fileserver-5.2.0.39122.GA-1.x86_64.rpm

MapR Client mapr-client-5.2.0.39122.GA-1.x86_64.rpm None
MapR Posix Client Basic mapr-posix-client-basic-5.2.0.39122.GA-1.x86_64.rpm mapr-client-5.2.0.39122.GA-1.x86_64.rpm
MapR Posix Client Platinum mapr-posix-client-platinum-5.2.0.39122.GA-1.x86_64.rpm mapr-client-5.2.0.39122.GA-1.x86_64.rpm
FileServer mapr-fileserver-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm
MapR Metrics mapr-metrics-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm
JobTracker mapr-jobtracker-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm

mapr-fileserver-5.2.0.39122.GA-1.x86_64.rpm

mapr-mapreduce-5.2-0.20.2.39122.GA-1.x86_64.rpm

NFS mapr-nfs-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm
Loopback NFS mapr-loopbacknfs-5.2.0.39122.GA-1.x86_64.rpm None
MapR Single Node mapr-single-node-5.2.0.39122.GA-1.x86_64.rpm

mapr-cldb-5.2.0.39122.GA-1.x86_64.rpm

mapr-fileserver-5.2.0.39122.GA-1.x86_64.rpm

mapr-nfs-5.2.0.39122.GA-1.x86_64.rpm

mapr-zookeeper-5.2.0.39122.GA-1.x86_64.rpm

mapr-webserver-5.2.0.39122.GA-1.x86_64.rpm

mapr-jobtracker-5.2.0.39122.GA-1.x86_64.rpm

mapr-tasktracker-5.2.0.39122.GA-1.x86_64.rpm

TaskTracker mapr-tasktracker-5.2.0.39122.GA-1.x86_64.rpm

mapr-core-5.2.0.39122.GA-1.x86_64.rpm

mapr-fileserver-5.2.0.39122.GA-1.x86_64.rpm

mapr-mapreduce-1.0-0.20.2.39122.GA-1.x86_64.rpm

MapR Upgrade mapr-upgrade-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm
Webserver mapr-webserver-5.2.0.39122.GA-1.x86_64.rpm mapr-core-5.2.0.39122.GA-1.x86_64.rpm

If you plan to use MCS to set up and manage table replication: mapr-hbase-1.1.1+

MapR Core 5.2 GA mapr-core-5.2.0.39122.GA-1.x86_64.rpm

mapr-core-internal-5.2.0.39122.GA-1.x86_64.rpm

mapr-hadoop-core-2.7.0.39122.GA-1.x86_64.rpm

mapr-mapreduce1-0.20.2.39122.GA-1.x86_64.rpm

mapr-mapreduce2-2.7.0.39122.GA-1.x86_64.rpm

MapR Core Internal mapr-core-internal-5.2.0.39122.GA-1.x86_64.rpm None
Hadoop Core mapr-hadoop-core-2.7.0.39122.GA-1.x86_64.rpm mapr-core-internal-5.2.0.39122.GA-1.x86_64.rpm
MapR History Server mapr-historyserver-2.7.0.39122.GA-1.x86_64.rpm mapr-mapreduce2-2.7.0.39122.GA-1.x86_64.rpm
MapReduce1 mapr-mapreduce1-0.20.2.39122.GA-1.x86_64.rpm mapr-hadoop-core-2.7.0.39122.GA-1.x86_64.rpm
MapReduce2 mapr-mapreduce2-2.7.0.39122.GA-1.x86_64.rpm mapr-hadoop-core-2.7.0.39122.GA-1.x86_64.rpm
NodeManager mapr-nodemanager-2.7.0.39122.GA-1.x86_64.rpm mapr-mapreduce2-2.7.0.39122.GA-1.x86_64.rpm
ResourceManager mapr-resourcemanager-2.7.0.39122.GA-1.x86_64.rpm mapr-mapreduce2-2.7.0.39122.GA-1.x86_64.rpm
ZooKeeper mapr-zookeeper-5.2.0.39122.GA-1.x86_64.rpm

mapr-core-5.2.0.39122.GA-1.x86_64.rpm

mapr-zk-internal-5.1.0.39122.GA-1.x86_64.rpm

ZooKeeper Internal mapr-zk-internal-5.2.0.39122.GA-1.x86_64.rpm None
SUSE (for SUSE installs only) mapr-compat-suse-5.2.0.39122.GA-1.x86_64.rpm None