Web Browser Security Issues

This section describes security issues with web browsers.

Web browsers and web servers often need to update their security requirements and configurations to ensure secure communication. Sometimes when web browser security requirements change, the browser is no longer able to connect to the MCS or other web interfaces.

The following fixes are available to resolve browser connection issues caused by changes in browser security requirements, or by an organization's need to maintain legacy (insecure) protocols:

Issue Affects MapR Version
Weak Ephemeral Diffie-Hellman Key 3.x, 4.x, and 5.0
Unable to Establish a Secure Connection 3.1.x, 4.0.x
Requirement to Enable Insecure Protocols (Not Recommended) 5.1
Note: Based on your MapR version, you may need to apply the fix for more than one issue.